Ada and Dishes [ADADISH](Solution)

AKSHAT KUMAR JAIN
3 min readDec 3, 2020

--

Chef Ada is preparing N dishes (numbered 1 through N). For each valid i, it takes Ci minutes to prepare the i-th dish. The dishes can be prepared in any order.

Ada has a kitchen with two identical burners. For each valid ii, to prepare the i-th dish, she puts it on one of the burners and after Ci minutes, removes it from this burner; the dish may not be removed from the burner before those CiCi minutes pass, because otherwise it cools down and gets spoiled. Any two dishes may be prepared simultaneously, however, no two dishes may be on the same burner at the same time. Ada may remove a dish from a burner and put another dish on the same burner at the same time.

What is the minimum time needed to prepare all dishes, i.e. reach the state where all dishes are prepared?

Input

  • The first line of the input contains a single integer T denoting the number of test cases. The description of T test cases follows.
  • The first line of each test case contains a single integer N.
  • The second line contains N space-separated integers C1, C2,…, CN

Output

For each test case, print a single line containing one integer ― the minimum number of minutes needed to prepare all dishes.

Constraints

  • 1≤T≤1,000
  • 1≤N≤4
  • 1≤Ci≤5 for each valid i

Subtasks

Subtask #1 (1 point): C1=C2=…=CN

Subtask #2 (99 points): original constraints

Example Input

3
3
2 2 2
3
1 2 3
4
2 3 4 5

Example Output

4
3
7

Explanation

Example case 1: Place the first two dishes on the burners, wait for two minutes, remove both dishes, and prepare the last one on one burner.

Example case 2: Place the first and third dish on the burners. When the first dish is prepared, remove it, and put the second dish on the same burner.

Example case 3: Place the third and fourth dish on the burners. When the third dish is prepared, remove it, and put the second dish on the same burner. Similarly, replace the fourth dish (when it is prepared) with the first dish on the other burner.

Solution

#include <iostream>
using namespace std;
void swap(int *xp, int *yp)
{
int temp = *xp;
*xp = *yp;
*yp = temp;
}
void selectionSort(int arr[], int n)
{
int i, j, min_idx;

// One by one move boundary of unsorted subarray
for (i = 0; i < n-1; i++)
{
// Find the minimum element in unsorted array
min_idx = i;
for (j = i+1; j < n; j++)
if (arr[j] > arr[min_idx])
min_idx = j;

// Swap the found minimum element with the first element
swap(&arr[min_idx], &arr[i]);
}
}
/* void printArray(int arr[], int n)
{
int i;
for (i = 0; i < n; i++)
cout << arr[i] << " ";
cout << endl;
} */

int main() {
int T,N,TT[4];
cin >> T;
int k = T;
while(k--){
cin >> N;
for( int i = 0; i < N; i++)
cin>>TT[i];


selectionSort( TT,N);
// printArray( TT, N);

int b1=0,b2=0;
for(int i= 0; i< N; i++){

if(b1==b2)
b1 += TT[i];
else if (b1>b2)
b2 += TT[i];
else if(b2>b1)
b1 += TT[i];
}

cout << max(b1,b2)<< endl;
}
return 0;
}

--

--

AKSHAT KUMAR JAIN
AKSHAT KUMAR JAIN

Written by AKSHAT KUMAR JAIN

Carpe diem!!🥳 Even if it kills you.

No responses yet